현재 버전

저라면 그런 업체는 피할 것 같습니다. SI 업체는 기술 자체보다도 고객사 환경에 맞춰서 개발하기 때문에 구버전을 써야할 일이 드문 건 아니지만, 정도 문제가 아닐까 싶습니다.

출시도 아니고 업데이트 중단된지 11년 지난 기술, 그 것도 어지간하면 하위 호환성을 보장하는 JVM을 그렇게 오래도록 방치하는 회사라면 고객사든 SI 업체든 무언가 개발자가 불합리하게 느낄 문제가 쌓여 있을 가능성이 높습니다.

아무도 기술에는 신경을 안 쓴다던가, 아니면 쓰는 사람이 있어도 의사 결정 과정에 문제가 있어서 아무도 의견 제시를 안 한다던가, 아니면 기술 책임자가 이상한 고집을 부린다던가 등등...

그런 걸 감안하면 저 같으면 대안이 없는 상황이 아니면 그런 업체는 피할 것 같습니다.


수정 이력

2021-01-13 15:23:01 에 아래 내용에서 변경 됨 #1

개인적으론 피할 것 같습니다. SI 업체는 기술 자체보다도 고객사 환경에 맞춰서 개발하기 때문에 구버전을 써야할 일이 드문 건 아니지만, 정도 문제가 아닐까 싶습니다.

출시도 아니고 업데이트 중단된지 11년 지난 기술, 그 것도 어지간 하면 하위 호환성을 보장하는 JVM을 그렇게 오래도록 방치하는 회사라면 고객사든 SI 업체든 무언가 개발자가 불합리하게 느낄 문제가 쌓여 있을 가능성이 높습니다.

아무도 기술에는 신경을 안 쓴다던가, 아니면 쓰는 사람이 있어도 의사 결정 과정에 문제가 있어서 아무도 의견 제시를 안 한다던가, 아니면 기술 책임자가 이상한 고집을 부린다던가 등등...

그런 걸 감안하면 저 같으면 대안이 없는 상황이 아니면 그런 업체는 피할 것 같습니다.