현재 버전

리액트네이티브 imagepicker 스프링으로 전송



@RequestParam(name = "images", required = false) MultipartFile file

스프링 코드구요


const handleChoosePhoto = () => {
const options = {
noData: true,
};
ImagePicker.launchImageLibrary(options, (photo) => {
if (photo.uri) {
//this.setState({ photo: response });
console.log('this')
setPhoto(photo)
console.log(photo)
const formData = new FormData();
formData.append("images", photo);
console.log(photo.fileName);
axios.post("http://192.168.1.251:8080/mobile/feed/upload",{
headers: {
"Content-type": "multipart/form-data"
}
}), formData;
// dispatch({
// type: UPLOAD_IMAGES_REQUEST,
// data: data,
// })
}
})
}

리액트코드입니다

위에 콘솔로그 photo찍음 나오는내용이구요


서버에러는 널값 떨어집니다..도대체 머가 문제일까요 어떻게 해결해야할까요ㅜ


수정 이력

2020-10-09 21:27:35 에 아래 내용에서 변경 됨 #2


@RequestParam(name = "images", required = false) MultipartFile file

스프링 코드구요


const handleChoosePhoto = () => {
const options = {
noData: true,
};
ImagePicker.launchImageLibrary(options, (photo) => {
if (photo.uri) {
//this.setState({ photo: response });
console.log('this')
setPhoto(photo)
console.log(photo)
const formData = new FormData();
formData.append("images", photo);
console.log(photo.fileName);
axios.post("http://192.168.1.251:8080/mobile/feed/upload",{
headers: {
"Content-type": "multipart/form-data"
}
}), formData;
// dispatch({
// type: UPLOAD_IMAGES_REQUEST,
// data: data,
// })
}
})
}

리액트코드입니다

이미지 피커 url찍으면 이형식으로 나오구요


서버에러는 널값 떨어집니다..도대체 머가 문제일까요 어떻게 해결해야할까요ㅜ

2020-10-09 21:27:16 에 아래 내용에서 변경 됨 #1


@RequestParam(name = "images", required = false) MultipartFile file

스프링 코드구요


const handleChoosePhoto = () => {
const options = {
noData: true,
};
ImagePicker.launchImageLibrary(options, (photo) => {
if (photo.uri) {
//this.setState({ photo: response });
console.log('this')
setPhoto(photo)
console.log(photo)
const formData = new FormData();
formData.append("images", photo);
console.log(photo.fileName);
axios.post("http://192.168.1.251:8080/mobile/feed/upload",{
headers: {
"Content-type": "multipart/form-data"
}
}), formData;
// dispatch({
// type: UPLOAD_IMAGES_REQUEST,
// data: data,
// })
}
})
}

리액트코드입니다

이미지 피커 url찍으면 이형식으로 나오구요


서버에러는 널값 떨어집니다..도대체 머가 문제일까요 어떻게 해결해야할까요ㅜ