하늬바람
520
2021-05-31 15:32:10 작성 2021-06-01 17:26:08 수정됨
1
133

[eclipse] sap-jco-manager-3.0.14.7.jar dependency를 적용한 build에 대한 질문


1) jar 파일 위치

    .../eclipse_projectDir/lib/sap-jco-manager-3.0.14.7.jar


2) build.gradle dependency

    implementation group: 'me.saro', name: 'sap-jco-manager', version: '3.0.14.7'


3) build 시 오류 내용

   Errors occurred while build effective model from C:\Project\gradle\caches\modules-2\files-2.1\me.saro\sap-jco-manager\3.0.14.7\ac55897d372301209cfd2b85b87688ef18b96d8d\sap-jco-manager-3.0.14.7.pom:

    'dependencies.dependency.systemPath' for com.sap.conn.jco:sapjco3:jar must specify an absolute path but is ${basedir}/lib/sapjco3.jar in me.saro:sap-jco-manager:3.0.14.7


${basedir} 이 설정되지 않아 위와 같은 오류가 발생하는 것으로 판단하고 여러가지 방법으로 basedir을 설정하여 빌드를 수행해 보는데 해결이 되지 않고 있습니다.

회원님들의 도움을 청합니다.

0
  • 답변 1

  • 하늬바람
    520
    2021-06-01 09:53:04

    원인은 sap-jco-manager-3.0.14.7.jar 파일에 내장된 maven 설정으로 인하여 발생하는 문제였습니다.

    build.gradle의 eclipse 관련 설정을 삭제하고 implementation files('lib/sap-jco-manager-3.0.14.7.jar') 를 추가하여 처리하였습니다.

    참고를 위하여 남깁니다.

  • 로그인을 하시면 답변을 등록할 수 있습니다.