고등어가어딨니
592
2021-04-06 09:06:50
10
799

새프로젝트 진행하려는데 버전이 좀 된 스프링부트


제가 cafe24 에서  톰캣 jsp 웹 호스팅을 사용하고 있거든요 ?


근데 서버환경의 버전이 낮은거같더라고요


위와 같습니다


어쩃든   보시면 톰캣 8.0 인데요   서버환경이랑 개발환경이 서로 맞아야되잖아요 ?

스프링부트는 톰캣이 내장되어 있어서  톰캣 8.0 인 스프링부트를 찾아보니깐


2018.6월이 있더라고요 부트 버전은 2.0.3.RELEASE 이고요


약 3년전건데 새 프로젝트하기에 괜찮을까요 ?  ( 웹 개발쪽은 첨이라서 -_-;; )

jdk 도 마리아db도 낮네요 ㅜ  저는 버전이 최신이면 좋은줄 알고있거든요 

미리 감사합니다  :D

0
  • 댓글 10

  • ROJAEKA
    157
    2021-04-06 09:12:27

    최신이면 좋지만, 자바 8과 부트 2 이상을 사용할 수 있는게, 저는 괜찮았습니다.

    자바 7과 8은 엄청난 차이를 가지고 있습니다. (람다 스트림, 병렬식...)

    저에겐 호스팅과 개발을 하기 위해서, 최소한의 스펙이랄까요?

  • 고등어가어딨니
    592
    2021-04-06 09:13:57

    아 그럼 저 서버환경버전도 나름 괜찮다는 말씀이신거죠 ?? 

  • ROJAEKA
    157
    2021-04-06 09:19:36 작성 2021-04-06 09:20:04 수정됨

    넹.  개인 플젝이나 장벽이 높을 필요가 없는 프로젝트라면 좋다고 생각합니다.

    더구나 한국회사라.. 한글이라는 장점 ㅋㅋㅋㅋㅋ

    혹시 개인프로젝트이신가요?


  • charlatan
    4k
    2021-04-06 09:20:13

    지원되는 JDK버전과 톰캣 버전을 미리 조사해보셔야 할 듯?

  • 고등어가어딨니
    592
    2021-04-06 09:22:36

    회사프로젝트입니다 규모가 큰건아닙니다 

    저혼자 맡게되었는데 이것저것 공부중입니다 

    버전조사도 해봐야겠네요 

  • ROJAEKA
    157
    2021-04-06 09:25:08

    회사 일이면.. 고민이 되실만 하군요.

    요즘 11이 기본인 회사도 꽤 있어서...

  • 만년코더
    9k
    2021-04-06 09:49:37

    회사 프로젝트면 AWS나 MS Azure로 갈아타자고 추천하시는게 어떨까합니다.

  • 케이론
    544
    2021-04-06 10:33:11

    war로 말아서 올리면 됩니다 
    어처피 jsp면 war로 마셔야 할거 같은데 

  • 고등어가어딨니
    592
    2021-04-06 10:39:12

    현재 회사에서는 cafe24를 사용중이여서 

    저도 이왕이면 그 길로 가고있습니다 ( 웹 신입수준입니다 , 혼자프로젝트 맡는거라서)

    그리고 war로 올리면 되기는한데 

    제가 우려하는건

    만약 로컬에서는 톰캣 9 를 사용하고  서버에서는 톰캣 8을 사용한다고 했을 때 

    이 톰캣버전에 의해서 로컬에서 실행되던게  서버에서는 실행이 안될 수 도있나 그 걱정입니다 

  • 케이론
    544
    2021-04-06 11:19:57

    톰캣은 버전은 자바 버전 따라 가신다고 생각하시면 되요 
    자바8쓰시면 톰캣8~ 이런식으로요 

  • 로그인을 하시면 댓글을 등록할 수 있습니다.