에에에?
42
2021-02-16 13:04:39 작성 2021-02-16 15:30:02 수정됨
0
74

Archive for required library 에러


자바 다이나믹웹프로젝트를 작업중인데


Archive for required library 에러가 발생하였습니다.


'~/lib/org.springframework.spring-library-3.1.2.RELEASE.libd' in project '~' cannot be read or is not a valid ZIP file 빌드패스 에러가 발생하여서


에러를 잡으려고 구글링 하다

1. maven update를 하면 된다하는데 해당 프로젝트는 maven이 아니고 다이나믹이라 maven이 존재X

2. 해당 libd파일을 새로 다운받아 해당 폴더에 넣어서 빌드패스시도 > 실패...

3. 자바 프로젝트에서 참조하고 있는 jar 파일이 정상적인 파일임에도

cannot be read or is not a valid ZIP file 오류가 발생하며 빌드가 안되는 경우에는

이클립스를 종료 한 후

워크스페이스 폴더 밑의 아래 두개 파일을 삭제한 후 

이클립스를 재기동하면 해결된다.

.metadata\.plugins\org.eclipse.jdt.core\invalidArchivesCache

.metadata\.plugins\org.eclipse.jdt.core\nonChainingJarsCache > 실패..


0
  • 답변 0

  • 로그인을 하시면 답변을 등록할 수 있습니다.