텐텐
136
2019-12-31 12:06:37
2
342

next.js + typescript에서 특정 모듈 import 시 SyntaxError가 뜹니다.


three.js 내부 모듈 FBXLoader를 사용하기 위해

import {FBXLoader} from 'three/examples/jsm/loaders/FBXLoader';

import 하였는데 

이런 에러가 뜹니다..

혹시 경험해보신분 알려주시면 감사하겠습니다ㅜ

0
  • 답변 2

  • 텐텐
    136
    2019-12-31 12:07:14

    react 환경에서는 잘되는데 next.js 에서 import 하면 이상하게 안되네요ㅜ

  • Dierslair
    5k
    2019-12-31 14:36:03

    트랜스파일 타겟과 라이브러리 필요 최소 ECMAScript 버전을 확인해주세요. 저는 이전에 Generator기반 라이브러리를 인터넷 익스플로러 타겟으로 트랜스했다가 안돌아가는 경우를 경험해봤습니다.

  • 로그인을 하시면 답변을 등록할 수 있습니다.