KW2
70
2019-12-03 21:35:44 작성 2019-12-03 21:36:53 수정됨
0
49

Configuration 'compile' is obsolete and has been replaced with 'implementation' and 'api' 경고


Configuration 'compile' is obsolete and has been replaced with 'implementation' and 'api' 

warning이 떠서 build.gradle 파일을 다음과 같이 수정을 완료했는데도 똑같은 경고가 뜨는데 원인이 무엇인지 모르겠습니다.

'api' 부분을 'implementation' 로 했을떄도 마찬가지 였습니다.

방법좀 알려주십쇼

apply plugin: 'com.android.application'

android {
    compileSdkVersion 26
    buildToolsVersion '27.0.3'
    defaultConfig {
        applicationId "com.kw2.kw2.pt_job"
        minSdkVersion 18
        targetSdkVersion 26
        versionCode 9
        versionName "1.8"
        testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}

dependencies {
    api fileTree(dir: 'libs', include: ['*.jar'])
    androidTestImplementation('com.android.support.test.espresso:espresso-core:2.2.2', {
        exclude group: 'com.android.support', module: 'support-annotations'
    })
    implementation 'com.android.support:appcompat-v7:26.+'
    implementation 'com.android.support.constraint:constraint-layout:1.0.2'
    implementation 'com.prolificinteractive:material-calendarview:1.4.3'
    implementation 'com.beardedhen:androidbootstrap:2.3.2'
    implementation 'com.google.firebase:firebase-ads:10.0.1'
    testImplementation 'junit:junit:4.12'
    api files('libs/CaulySDK_3.4.18.jar')
}

apply plugin: 'com.google.gms.google-services'

WARNING: Configuration 'compile' is obsolete and has been replaced with 'implementation' and 'api'.

0
0
  • 답변 0

  • 로그인을 하시면 답변을 등록할 수 있습니다.