3
133

IOS Xcode 버전 관련 도움좀 주세요


안녕하세요 선배님들

Mac으로 IOS 앱 개발중인데요

Xcode를 7.3.1이랑 10.1 두가지 버전을 쓰고있었어요.

7.3.1은 구버전 앱을 빌드하는 용도로 쓰고있었고, 10.1은 신규버전 제작중에 사용하고있었습니다.

10.1버전 디바이스 빌드시 버전문제로 이번에 MAC OS를 하이시에라에서 카타리나로 올렸는데, 7.3.1버전이 실행이 안되더라구요 ㅠㅠ

제가 IOS는 처음이라 아직 잘 몰라서그러는데 분명 구버전 신버전 Xcode를 나눠썻다는건

해당 버전이 아니면 정상작동 안하는게 있어서 그런거같거든요..

XCode버전에 따른 빌드가 문제가 발생될 요소같은게 있나요??

단순 IDE로 알고있었는데 그게 아닌가봐요 흠... 도움좀 부탁드립니다 ㅠㅠ


요약

1. Xcode 두가지 버전 사용중 (7.3.1, 10.1)

2. 10.1버전에서 디바이스로 빌드가 안되서 OS업데이트 및 Xcode업데이트 진행

3. MAC 하이시에라에서 카타리나로 올린뒤 7.3.1실행안됨

4. 10.1버전에서 7.3.1 소스 추가하여 쓰려고하는데 문제 될 요소가 있는지 모르겠음


도움 부탁드립니다 ㅠㅠ


0
0
  • 답변 3

  • Pot_Lid
    83
    2019-10-11 12:06:12

    구버전 32비트라 그런거 아닐까요

    1
  • 로직X
    452
    2019-10-11 13:51:00 작성 2019-10-11 13:52:27 수정됨

    맥 OS는... 잘따져서 올려야합니다. os 올리시면 xcode 에서

    빌드 할수 있는  ios 버전이 달라집니다. ㅜㅠ

    구버전 신버전을 나눠서 소스를 해논이유가 있을꺼에요.

    문제는.. 한번 올리면 편법쓰던가 ... 못내린다는 문제가

    1
  • 끄앙 감사합니다 ㅠㅠ

    결국 다운그레이드 하기로했고 새로운 프로젝트는 신규 개발장비 맞춰서 가기로했어요 감사드려요

    1
  • 로그인을 하시면 답변을 등록할 수 있습니다.