내맘속풍요
122
2019-07-22 20:33:43
7
277

메이븐 스프링3 에서 4 업그레이드 하는데 오류가 나네요


조언좀 부탁드립니다 ㅠ

레거시 프로젝트 생성 이후
스프링4버전으로 업그레이드 하기위해 pom.xml 만 수정하는데요

블로그에 친절하게 된게 많아서 보고 똑같이 따라 하는데 안되네요

Repository 지우고 다시 받기를 여러번이네요
서블릿api 는 죽어도 변경이 안됩니다 ㅠㅠ

2.5 에서 3.0.1 로 바꾸는게 왜이렇게 안되죠;;
라이브러리 추가 되었는데도 찾을수없다 불러올수없다 

혹시 메이븐은 인터넷 환경에 영향을 많이 타나요??
아님 repository를 여러개 써봐야 할까요?

조언좀 부탁드려요
프로젝트 생성이 왜이리 안되는지;;

0
0
  • 답변 7

  • kenu
    46k
    2019-07-22 20:51:12

    에러 메시지 부탁드립니다.


    0
  • 내맘속풍요
    122
    2019-07-22 21:06:59


    Missing artifact javax.servlet:servlet-api:jar:3.0.1
    pom.xml
    Maven Dependency Problem
    The container 'Maven Dependencies' references non existing library 'C:\Users\ssson\.m2\repository\javax\servlet\servlet-api\3.0.1\servlet-api-3.0.1.jar'
    project
    Build Path Problem
    The project cannot be built until build path errors are resolved
    projectJava Problem
    The superclass "javax.servlet.http.HttpServlet" was not found on the Java Build Path
    home.jspJSP Problem
    0
  • 내맘속풍요
    122
    2019-07-22 21:08:28
    tomcat에 올라가서는 일단 실행은 되는데 메이븐으로 안받아지니까 답답하네요;;
    0
  • kenu
    46k
    2019-07-22 21:11:29

    C:\Users\ssson\.m2\repository\javax\servlet\servlet-api\3.0.1\servlet-api-3.0.1.jar 경로에 파일 있나요?



    0
  • 내맘속풍요
    122
    2019-07-22 21:16:31

    아 너무 쉬운걸 틀렸네요 확인해보니까

    <artifactId>servlet-api</artifactId>

    이렇게 해버렸네요 


    <artifactId>javax.servlet-api</artifactId>

    이렇게 변경했습니다.


    시간내주셔서 감사합니다. 창피하네요 ;;ㅎㅎ;;

    0
  • kenu
    46k
    2019-07-22 21:29:28

    다행입니다. 

    인생은 창피함의 연속이라 적.당.히 뻔뻔해 지셔야 됩니다. 

    덕분에 저도 javax.servlet-api 배웁니다. 감사합니다. :)

    0
  • 내맘속풍요
    122
    2019-07-22 21:43:28
    ^^ㅎㅎ
    0
  • 로그인을 하시면 답변을 등록할 수 있습니다.