열심히배웁시다
1k
2019-02-24 22:51:25
8
726

인텔리j 톰캣 실행이 안되는 경우,


혼자 해볼게 있어서 web프로젝트 하나 만들고 건드려 본 다음 삭제를 했는데,,

그 이후로 만드는 웹 프로젝트에 톰캣을 붙여도 계속 같은 오류가 나네요.


기존에 작업하던 웹 프로젝트는 멀쩡히 잘 됩니다.


이럴때는 어디가 고쳐진 건가요..?

server.xml은 건들지도 않았는데, 난감하네요.




0
0
  • 답변 8

  • mixMaven
    1k
    2019-02-24 22:59:05

    보통은 톰캣이 제대로 shutdown 되지 않아서 그 톰캣이 1099 포트를 잡고 있어서 그런 경우가 생기는걸로.. 컴퓨터를 재시작하든 컴퓨터 구조를 잘 이해하고 있다면 sh, bat 파일로 톰캣 프로세스를 한번 죽여보고 재 실행해보심을 ㅎㅎ

    0
  • 열심히배웁시다
    1k
    2019-02-24 23:02:56

    mixMaven


    예 이미 재부팅해봤는데 계속 그러네요,


    다른 프로젝트는 다 실행이 잘 되고, 스프링으로 새 프로젝트를 만들어도 잘 되는데

    그냥 아무거도 안붙인 웹 프로젝트 생성해서 실행하면 계속 오류가 납니다.


    근데 로그보면 catalina.sh에 ;가 빠졌다는 듯한 메세지가 나오고....

    저럴 수가 있나요??

    0
  • mixMaven
    1k
    2019-02-24 23:07:33

    catalina 실행경로보니까 Mac 쓰세요?

    맥이시면 터미널에서 1099 포트 사용중인지 확인해보시죠~

    https://stackoverflow.com/questions/38986910/intellij-idea-address-localhost1099-is-already-in-use

    0
  • 열심히배웁시다
    1k
    2019-02-24 23:09:52 작성 2019-02-24 23:10:08 수정됨

    mixMaven


    네 설정된 포트 다 확인해봤는데 안됩니다. 동일 포트 사용하는 여러 다른 프로젝트는 켜도 실행이 되는데,,,

    천천히 알아봐야겠네요.


    답변 감사합니다.


    0
  • adtech_so
    171
    2019-02-24 23:23:00

    "JAVA_OPTS" 를 설정할 때 오타가 난 부분이 있는 것 같군요.

    syntax error near unexpected token `('


    0
  • 열심히배웁시다
    1k
    2019-02-24 23:29:54

    adtech_so 그러면,, 다른 프로젝트는 동일한 톰캣 서버를 사용하는데도 작동하는 이유가 무엇일까요?

    0
  • adtech_so
    171
    2019-02-25 00:19:22

    https://github.com/apache/tomcat85/blob/trunk/bin/catalina.sh#L394 라인에 설정되어 있는 환경변수 중에서 위의 오류가 발생되었으니 하나하나 찍어보시는 편이 좋을 것 같네요.

    0
  • 열심히배웁시다
    1k
    2019-02-25 08:49:22

    원본 파일과 제가 가지고 있는 파일 비교해봐도 완전히 일치하는걸로 나오는데,,

    어디서부터 찾아봐야 할까요?

    0
  • 로그인을 하시면 답변을 등록할 수 있습니다.