열정개발자
383
2018-10-16 15:36:38
13
2833

자바스크립트가 싫습니다.


왜 자바스크립트는 브라우저마다 아직도 호환이 힘든가요?

ES6, ES7 이 나오면 뭘 합니까???

어차피 브라우저마다 안되서 쓸 수 있는게 한정적인데...

참고로 IE8 에서 변수 선언할 때 var 대신 let 사용 가능한가요?

-1
1
  • 댓글 13

  • 홀리
    448
    2018-10-16 15:42:32

    자바스크립트가 문제가 아니라 쓰지말라고 서비스지원까지 끝낸 옛 브라우저를 쓰는거 자체가 문제 인것 같습니다. 

  • 독거소년님닉넴너무좋아요
    1k
    2018-10-16 15:44:49

    IE8 ???

  • 니플
    2018-10-16 15:47:09

    js는 버그나 오류를 수정하기 위해 ES7까지 나온 것인데

    그렇게했는데 브라우저에서 호환하지않는 것은

    브라우저문제입니다.ㅎㅎ


    IE에서 사용할려면

    바벨을 사용하면 됩니다.

    https://jaeyeophan.github.io/2017/05/16/Everything-about-babel/

  • 열정개발자
    383
    2018-10-16 16:28:17

    제가 IE8 을 쓰겠다는 뜻이 아닙니다.

    저는 일개 개발자입니다. 저는 자동으로 업그레이드 되는 크롬을 사용합니다.

    따라서 최신 버전이라고 할 수 있죠...

    문제는 제가 개발한 것을 IE8, 9, 10에서 돌려 보는 놈들이 있기 때문입니다.

    왜 IE8,9,10 에서 제가 만든 것을 돌리냐고요? 여기서도 나와야 플젝이 성공이기 때문에 테스트한답니다.

    웹호환성인가 뭔가.... 그러니 한국에서 JS 가 발전이 없어요 ㄷㄷ


    -3
  • 니플
    2018-10-16 16:36:22

    바벨 쓰시면 됩니다.

    바벨 쓰세요

  • Junsik
    411
    2018-10-16 16:51:40

    원래 일반 사용자가 사용하는 클라이언트 프로그램들은 모두 겪을 수 밖에 없는 문제이긴 하죠.

    안드로이드/ios와 같은 모바일 쪽에서도 파편화는 늘 골치덩어리니까요.

    물론 자바스크립트가 특히 심하다는 것은 인정합니다 ㅎ

  • 마쓰시타
    544
    2018-10-16 16:53:59

    열정개발자 / 즈기요.. 외국에서도 IE 테스트 다 합니다. 안하는 곳이 이상한거구요


    JS개발이 싫으시면 백엔드만 전문적으로 하는 개발 자리를 알아보시면 좋을듯


    한국 JS 발전은 알아서 잘 하고 있슴다

  • reistrem
    159
    2018-10-16 16:58:08

    자바도 싫습니다. ㅋㅋㅋ

  • Chaed
    2k
    2018-10-16 17:33:51

    언어의 문제라기보단 하위호환에 대한 지원이 문제이지 않을까 싶네요

    안드로이드의 하위 OS지원도 같은 맥락일것입니다.

  • 농약먹는아이들
    116
    2018-10-16 17:43:33

    웹개발자도 개발자냐고 자신있게 지껄이더니 ㅋㅋ 스크립트는 또 어렵나보오

  • 즈루시
    2018-10-16 17:48:25 작성 2018-10-16 22:36:56 수정됨

    모두가 인터넷이 되고 최신 컴퓨터를 가지고 있는게 아니니까요

    제약적인 환경에서 주어진 도구를 가지고 클라이언트가 원하는 최선을 다하는게 용역 개발 아입니꽈...

    자기 개발로는 최신을 추구하지만요...

  • Aaron
    1k
    2018-10-16 18:21:33

    작성자의 기분을 이해하긴 하지만...

    사용자 입장에서는 IE든 크롬이든 알바 아니죠...

    개발자로서는 고객이 원한다면 지원해주는게 숙명이지 않을 까요...?

    웹 호환성 테스트는 그런 사용자들을 위해 하는 거고요...

    진정한 프로로 가는 길이라고 생각하면 좋을 것 같습니다.

  • 북삼촌사람
    1k
    2018-10-16 18:53:26

    바벨, 폴리필 라이브러리로 IE8 커버해야죠 ㅎ 

  • 로그인을 하시면 댓글 을 등록할 수 있습니다.