zxc123
182
2018-09-28 15:58:47
1
604

centos5에 mysql 5.7 버전 소스 설치중 cmake 에러


centos5에 mysql 5.7 버전 소스 설치중 cmake 에러입니다


CMake Error at cmake/os/Linux.cmake:28 (MESSAGE):

  GCC 4.4 or newer is required!

Call Stack (most recent call first):

  CMakeLists.txt:162 (INCLUDE)


이런 에러가 발생하는데

gcc -v  , g++ -v 입력시 4.8버전으로 나옵니다
기존에 4.1버전이였는데 devtoolset-2 설치해서  symbolic link 로 devtoolset 에 설치되어 있는 gcc를 연결해서 버전을 높였습니다 근데도 cmake시 위에 같은 에러가 발생하는데 왜그럴까요...?
0
  • 답변 1

  • kasamaki
    31
    2018-12-27 15:23:49

    scl enable을 통해 상위버전 gcc를 혹시 활성화시키셨나요?
    ex) scl enable devtoolset-2 bash

  • 로그인을 하시면 답변 을 등록할 수 있습니다.