pianoman
553
2018-08-03 16:49:08
3
536

톰캣 오류 확인부탁드립니다.


전자정부프레임웤 3.6

자바 1.8

톰캣 8.0

이렇게 씁니다.

오류가 뜨는데, 검색을 해보니 같은 오류가 많이 있네요.


크게 검색해보니

Failed to start component [StandardEngine[Catalina].StandardHost[localhost].StandardContext[]]

이놈으로 검색이 되던데


해결방법이 servlet-api.jar파일 버전 맞춰주고 해결된분

.m2/repository 안에 내용 삭제하고 메이븐 업데이트 해서 해결된분 등등 있으시던데,

저는 이것저것 다 해봐도 안되네요...


저 오류의 가장 주요한 포인트가 servlet-api.jar 파일의 버전문제인것 같은데,

버전을 뭐랑 뭐랑 어떻게 맞춰줘야 하는건지 아시는 분계시는지요?


참고로 컴터 뻑나서 완전포맷 -> 윈도우설치 -> 개발환경세팅 중입니다...



0
  • 답변 3

  • 더미
    18k
    2018-08-03 16:59:32
    (3.6 이상) JavaEE(J2EE) 7 혹은 JDK1.7 이상의 환경
    1. Servlet 3.1 사용
  • pianoman
    553
    2018-08-03 17:10:07

    servlet 3.1 사용이면 아파치 8.0 안에 있는 servlet-api.jar를 jdk쪽 폴더에 복사하고 dependency 버전 3.1로 수정해주면 되는건가요? 


  • 더미
    18k
    2018-08-03 17:30:39
    복사까지 할 이유는 없고 버전만 맞춰주면 될거 같군요
  • 로그인을 하시면 답변을 등록할 수 있습니다.