Yonggggg
798
2018-07-13 12:55:43
6
898

우분투 16.04 에 php 5.5.9 설치를 어떻게 하나요?


옛날 서버에 셋팅되어있는 웹서버를 옮겨야 하는데 


새로운 서버의 우분투 버전이 16.04 입니다 

그런데 웹서버가 php5.5.9 버전으로 코딩되어있어서 버전을 맞춰주려고 합니다. 

우분투 16.04 부터는 php 5.6, php7  이상부터 안전하게 지원한데서 php 5.5.9 설치는 추천하지 않더라구요 

우분투16.04에 php5.5.9 버전을 설치하는 가이드라인 나와있는 사이트가 있을까요?


0
0
  • 답변 6

  • Binple
    204
    2018-07-13 13:09:48 작성 2018-07-13 13:12:02 수정됨

    https://askubuntu.com/questions/756181/installing-php-5-6-on-xenial-16-04
    https://www.geekysaur.com/information-technology/server-administration/install-php-5-5-or-5-6-in-ubuntu-16-04-lts-xenial-xerus/

    참고 해보심이...

    1
  • Yonggggg
    798
    2018-07-13 13:14:26

    봤던건데 

     ppa:ondrej/php 에서 5.5 버전을 더이상 지원 안하더라구요
    다른 방법은 없을까요?
    0
  • Binple
    204
    2018-07-13 14:26:14 작성 2018-07-13 14:34:54 수정됨

    http://kr.archive.ubuntu.com/ubuntu/pool/main/p/php5/

    아직 저장소에 있는 걸로 보아 바이너리 파일 다운 받아서 수동으로 설치하시면 될 거 같아요.

    https://launchpad.net/~ubuntu-security-proposed/+archive/ubuntu/ppa/+build/7336663

    런치패드에도 있는거 보니 저장소 추가해서 버전 지정해서 설치 하시면 될 거 같고요.

    ppa:ubuntu-security-proposed/ppa


    1
  • Yonggggg
    798
    2018-07-14 12:11:16

    오오 이따 해봐야겠네요. 리눅스 다루는게 초보라서 새로운걸 또 배웠네요! 정말 감사합니다.

    0
  • Yonggggg
    798
    2018-07-15 12:31:11 작성 2018-07-15 16:48:45 수정됨

    php5.5.9 가 우분투 14버전으로 되어있는거 같은데  우분투16에 설치해도 문제없나요?

    런치패드 저장소 확인해보면 php5.5.9 파일있는데 ppa:ubuntu-security-proposed/ppa 로 저장소 설치하고 보면 없어서 수동으로 설치해줬습니다. 그런데 우분투16버전과 호환이 잘 안되는거 같습니다. 

    dpkg: dependency problems prevent configuration of php5-json:

     php5-json depends on ~~~

       package php~~ is not installed.

    이런 오류가 패키지 설치할때마다 뜨네요 ㅠ


    0
  • Binple
    204
    2018-07-16 09:49:38 작성 2018-07-16 09:50:33 수정됨

    php5-json 의존성 문제구요.

    수동으로 설치 하셨다고 하셨으니..

    php5-json 을 먼저 설치 해보세요.

    http://kr.archive.ubuntu.com/ubuntu/pool/main/p/php-json/

    바이너리 파일이라 의존성만 맞으면 특정한 것 아닌이상 우분투16에서도 잘 되실꺼에요.

    1
  • 로그인을 하시면 답변을 등록할 수 있습니다.