max_2017
10
2018-06-21 11:09:26
2
721

스프링에서 oracle과 jdk 버전에 따른 jdbc 설정


스프링을 사용하고 있는 입문개발자입니다.

DB를 연결하려고 합니다. 사용하는 DB는 오라클이구요.


현재 오라클11g 사용중이고 jdk는 1.8버전을 사용중입니다.


pom.xml에 드라이버를 추가할때 무슨 버전을 추가해줘야 하는지 잘 모르겟네여ㅠㅠ

그리고 jdbc버전은 jdk버전에 맞춰야하는지 oracle 버전에 맞춰야 하는지...


아직 입문이라 모르는게 많습니다..


고수님들의 조언 부탁드립니다.

0
0
  • 답변 2

  • 바냐파노
    1k
    2018-06-21 12:24:32

    ojdbc6 쓰시면 됩니다.

    0
  • catsfriend
    2k
    2018-06-21 13:20:19

    oracle 9i 까지는 ojdbc4, jdk 1.6 사용하시면 되고  그 이후부터는 ojdbc6 1.6 이상 쓰시면 됩니다

    0
  • 로그인을 하시면 답변을 등록할 수 있습니다.