Ssakdukja
20
2018-06-13 16:46:05
2
267

안드로이드 스튜디오 compile implementation 관련 질문입니다.


구버전 소스를 사용하려고하는데

Configuration 'compile' is obsolete and has been replaced with 'implementation'.

이러한 오류로 자바부분에서 실행이 안되어 구글링을 해보았더니 해결방법이 안나오네요

플랫폼의 버전을 내리는 방법 외에 기존 자바 코드내에서 수정을 통하여 사용을 할 수는 없는건가요?

수정하여 사용 할 수 있다면 어떻게 수정해야 하는지 궁금합니다!
0
0
  • 답변 2

  • EF
    585
    2018-06-13 23:21:25

    Gradle 에서 google service 버전을 최신으로 올려보세요.

    0
  • John84
    2k
    2018-06-14 09:01:01

    compile를 implementation로 바꿔보세요

    버전이 정확히 기억이 나지 않지만 3.0에서는 혼용 

    이후버전에서는 implementation만 사용 가능한걸로 알고 있습니다




    0
  • 로그인을 하시면 답변을 등록할 수 있습니다.