문신입
108
2017-08-22 14:43:06
1
251

spring security, spring version 바꾸던 와중에 난 오류입니다.


저기 16번째 줄에서 오류가 납니다. 밑에 보면 에러 났다고 뜨고 로그에서 자세히 확인 하라고 하네요. 
오류가 원래 제가 spring 3.1.1 버전을 쓰다가 spring 4.3.4 버전으로 바꾸던 와중에 났습니다. 
이렇게 물어봐도 될지는 모르겠지만 혹시 아신다면 가르쳐주시면 감사하겠습니다.!


0
  • 답변 1

  • 20523
    1k
    2017-08-22 15:49:13

    Java를 사용하면서, 버전을 급하게? 바꾸어서는 안 되는 것이 몇가지 있습니다.

    1. Java 버전. - Java 1.3, Java 1.4, Java 5, Java 6, Java 7, Java 8

    2. (웹인경우) Servlet 버전. - Servlet 2.3, Servlet 2.4, Servlet 2.5

    3. 프레임워크 버전. - 프레임워크의 경우, 위의 2개에 의존하는 부분이 있습니다.


    그래서, 단순 마이너 버전 업데이트가 아닌, 버전(메이저)을 바꿀 경우, 바꿀 수 있는 환경인지 검토가 필요합니다.


    단순하게, Tomcat을 사용하는 환경이라고 하면, Tomcat 버전에서 사용할 수 있는 버전이 무엇인지는, 아래와 같은 페이지를 통해서 참조할 수 있습니다.

    http://tomcat.apache.org/whichversion.html

    (물론, spring에서 제공하는 정보는 위의 tomcat이 제공하는 표와 같은 동일한 것은 제공하지 않을 수 있습니다.)


    그래서, spring 3에서 spring 4로 바꾼다고 하면, 바꾸어도 상관없는지, 그리고 영향을 받는 부분이 어디까지인지 확인하고 바꾸어야 합니다.


  • 로그인을 하시면 답변을 등록할 수 있습니다.