웃는신입개발자
86
2017-01-17 10:33:37
2
4149

이클립스 실행에러


안녕하세요 신입개발자 입니다.

에러로그 올라오는데 원인을 찾지못해 글올립니다.


org.springframework.beans.factory.BeanDefinitionStoreException: Failed to read candidate component class: file [C:\Users\Administrator\workspace\.metadata\.plugins\org.eclipse.wst.server.core\tmp6\wtpwebapps\theonepay\WEB-INF\classes\com\archone\theonepay\admin\controller\AdminController.class]; nested exception is org.springframework.core.NestedIOException: ASM ClassReader failed to parse class file - probably due to a new Java class file version that isn't supported yet: file [C:\Users\Administrator\workspace\.metadata\.plugins\org.eclipse.wst.server.core\tmp6\wtpwebapps\theonepay\WEB-INF\classes\com\archone\theonepay\admin\controller\AdminController.class]; nested exception is java.lang.IllegalArgumentException

(중략...)

이런 에러가 올라오는데,

상황 : svn 에 올라와져있는 프로젝트를 체크아웃 받아서 실행했을때 에러가 나옵니다.

1. 해당 프로젝트를 공유하고 있는 다른 pc 에서는 실행이 잘됨.

2.해당 에러의 클래스파일 위치가 제대로 있음...

3. 프로젝트 클린 해봄 -> 그래도 안됨

4.워크스페이스를 새로파서 svn 계정연결후 다시 체크아웃받아서 실행 -> 안됨

5. 해당 클래스파일을 따로 빼서 적용해봄 -> 안됨..


에러내용에 맞게 할수 있는 조치는 한거 같은데 뭐 다른걸 체크해야될 상황이 있나요...

 희안하네요 ㅠㅠㅜ


0
  • 답변 2

  • 김마리
    278
    2017-01-17 11:03:51

    급하시면 다른 pc 이클립스랑 워크스페이스 통째로 복사해와서 하세요. 저거 잡는거 보다 빠를듯

  • 웃는신입개발자
    86
    2017-01-17 11:42:22
    원인 찾았습니다. 자바 버젼이 1.8이었는데 1.7로 재세팅 하니까 잘되네요
  • 로그인을 하시면 답변을 등록할 수 있습니다.