konggirl
10
2015-02-24 10:17:02
2
2116

500에러가 뜨는 이유 질문합니다.


트위터 api와 관련된 소스 코드를 실행하려고 합니다.

이클립스에서 import한 후 톰캣 7.0, jre6에서 오류나서 삭제후 jre7로 바꿨습니다.

라이브러리는 twitter4j를 추가했고요.

consumer_key와 secret 값 저장도 했습니다.

이클립스에서는 ReqestToken에 대한 에러는 안나는데 로컬에서 실행하면 500에러가 뜨는 이유가 뭔지 궁금합니다.

org.apache.jasper.JasperException: Unable to compile class for JSP: 

An error occurred at line: [1] in the generated java file: [C:\workspace\.metadata\.plugins\org.eclipse.wst.server.core\tmp0\work\Catalina\localhost\twt\org\apache\jsp\signin_jsp.java]
The type twitter4j.auth.RequestToken cannot be resolved. It is indirectly referenced from required .class files

An error occurred at line: [15] in the generated java file: [C:\workspace\.metadata\.plugins\org.eclipse.wst.server.core\tmp0\work\Catalina\localhost\twt\org\apache\jsp\signin_jsp.java]
Only a type can be imported. twitter4j.auth.RequestToken resolves to a package

An error occurred at line: 16 in the jsp file: /signin.jsp
RequestToken cannot be resolved to a type
13: 
0
0
  • 답변 2

  • 너부리
    796
    2015-02-24 10:35:30
    The type twitter4j.auth.RequestToken cannot be resolved. It is indirectly referenced from required .class files
    3
  • 허리펴
    1k
    2015-02-24 13:14:16

    타임라인 불러오거나 글쓸때 리퀘스트 토큰이 필요한데

    로그인처리가 안되어있는거같네요

    0
  • 로그인을 하시면 답변을 등록할 수 있습니다.