kenu
50k
2014-09-27 07:30:14
2
2863

Bash 쉘 취약점과 패치법


env VAR='() { :;}; echo Bash is vulnerable!' bash -c "echo Bash Test"
명령으로 Bash is vulnerable! 결과가 보이면 취약점이 있는 버전입니다. 시스템 패치를 통해서 해결할 수 있습니다.

관련글: https://www.digitalocean.com/community/tutorials/how-to-protect-your-server-against-the-shellshock-bash-vulnerability




맥은 아직 패치가 나오지 않았습니다.

관련글: http://mashable.com/2014/09/25/how-to-protect-yourself-from-shellshock-the-bash-bug-that-might-be-worse-than-heartbleed/
0
  • 댓글 2

  • siva6
    5k
    2014-09-29 13:06:46
    mac homebrew로 bash설치하면 됩니다.
    금요일에는 4.3.25였는데..
    오늘 업그레이드 하니 4.3.27로 올랐네요.

    기존은 warning 발생하고 실행되더니,
    지금 것은 warning도 없네요.
  • junya0803
    253
    2014-09-30 15:07:43
    감사합니다. IBM AIX 서버인데 위 명령어가 작동안하는 걸로 보아 bash 를 사용하지 않는 거겠죠?
  • 로그인을 하시면 댓글 을 등록할 수 있습니다.