illilli
22
2021-12-04 22:18:52
1
171

스프링 설치 관련 에러입니다. legacy project 만들고 싶어요...ㅠ


안녕하세요? 기존 노트북이 오래되어 새로운 노트북을 사고, 잘 해보고자 하였으나,, 
이상하게 스프링 설치부터 갑자기 안됩니다.(같은 설치 프로그램을 사용하고 있습니다. sts4버전이요~)

조금만 조언해주시면 감사드리겠습니다. 스프링의 이클립스 마켓플레이스에서 sts 관련 설치를 에러 없이 잘 마치고, legacy project 를 new 할 수 있는 게 목표에요~

1. 스프링의 이클립스 마켓플레이스에서 sts 검색 후 이것저것 (spring 관련하여) 다운 받으려고 하면
(2. 목록 참고) 에러 메세지가 나옵니다. 
'Problems occurred while performing provisioning operation: operation plan must be resolved

operation plan must be resolved ' 이렇게요. 그러면서 설치가 안됩니다. 
(처음부터 이런 메세지가 뜨니까, 스프링 실행 잘 되더라도, 언제 한 번쯤 잘 안될 것 같은 불안감이 있고 굉장히 찝찝하네요ㅠ)


2. 스프링의 이클립스 마켓플레이스에서 sts 검색 관련된 것은
1) spring tools 3 add on for spring tools 4 3.9.19 snapshots  --설치되었습니다.
2) spring tools 3 (standalone edition) 3.9.14. relase -- 1. 이유로 설치가 안됩니다.
3) spring tools4(aka Spring tool suite 4) 4.12.1 release --설치되었습니다.
입니다.


3. 이클립스 마켓에서 sts 검색해서 'spring tools 3 add-on~release' 설치하고 싶지만, 

그게 없습니다. 2.에서 설치가 잘 안 되어서 인지, spring legacy project 를 만들 수 없습니다.


도대체 어찌해야 할까요? 스프링 다 지우고, 재설치해봤지만 결과는 같았습니다...ㅠ

제가 스프링 위에서 뭐라도 시작할 수 있게 도와주시면 감사하겠습니다...ㅠㅠㅠ

0
  • 답변 1

  • 한국은역시자바
    1k
    2021-12-05 02:03:00

    왜 레거시를 설치하시려고 하나요? 스프링 부트를 생성하세요.

  • 로그인을 하시면 답변을 등록할 수 있습니다.