똘똘이박사
1k
2021-12-04 17:27:46
7
1132

공공기관.. 차세대 하는데 왜 자바 버전이 아직도 1.6…?????


안녕하세요

요즘 공공기관 프로젝트를 하고 있는데요

차세대 한다고 들어가 갔는데 자바 버전이 아직도 1.6 입니다.

기존 시스템에서 뭘 가져 오는 것도 아니고… DB만 그대로일 뿐인거 같은데…

왜 아직도 1.6을 못 벗어 나는 걸까요?

0
  • 댓글 7

  • testaa
    1k
    2021-12-04 17:35:55

    누구나 와서 개발할수있어야하기떄문이죠 개발하향평준화가 되야 누구든 손쉽게 고칠수있죠

  • kenu
    58k
    2021-12-04 18:03:26

    1.8은 되어야 합니다.

    Release FamilyEnd Of Support Life (EOSL)
    18September 2022(1)
    17 LTSSeptember 2029
    16September 2021
    15March 2021
    14September 2020
    13March 2020
    11 LTSSeptember 2026
    10September 2018
    9March 2018
    8 LTSDecember 2030
    7 LTSJuly 2022
    6 LTSDecember 2018
    5 LTS

    July 2015

    from: https://okdevtv.com/mib/java

  • liver
    211
    2021-12-04 18:12:14

    ㅋㅋㅋ 코틀린은 영원히 안쓰겠네

  • scsc
    818
    2021-12-04 19:23:06

    공공이 그렇죠

  • 쿡쿠
    2k
    2021-12-04 21:24:49

    차세댄데 1.6은 심하네요. 서버는 안 올리나 보죠?

  • pooq
    8k
    2021-12-04 22:58:04

    1.연관된 중요한 서비스 한두개 때문에 걸려서 자바 버전을 못 올리는 경우

    2.차세대 대상이 전체가 아니라 특정 사이트 한두개나 일부만 계획된 경우

    3.공통 부분이 1.6으로 개발되었는데 너무 잘 만들어놔서 절대 포기 못하는 경우

  • 천사와악마
    2k
    2021-12-05 19:55:19

    1.6은 당장 TLS 1.2 이하 지원중단 이슈 때문에라도 올라가야 하지 않나요?

    이거 끝내고 또 차세대 하려나 봅니다? 

  • 로그인을 하시면 댓글을 등록할 수 있습니다.