스프링링링
611
2021-08-18 17:23:56
3
242

파이참 interpreter 오류랑 pip 모듈 설치 오류 ㅠㅠ


하.. 원래 파이썬이랑 파이참 잘 쓰고 있었는데 

이번에 git이랑 이것저것 추가하면서 공부하던 중에 갑자기 configure python interpreter 오류가 뜨네요..

해결 방안 찾아서 해봐도 파이참 껐다 키면 같은 오류가 계속 떠요,,, 무슨 경로가 잘못 된걸까요 ? ㅠㅠ

사수님한테 여쭤보니 그냥 에디터 쓰지말고 파이썬 셸에서 사용하라던데 매번 cd로 폴더 찾아다니고 notepad 로 열어서 수정하기도 영 불편해요 ㅠㅠ

글구 모듈 사용할때도 원래 pip install 로 잘 했었는데


ERROR: Could not find a version that satisfies the requirement smtplib
ERROR: No matching distribution found for smtplib
WARNING: You are using pip version 21.0.1; however, version 21.2.4 is available.
You should consider upgrading via the 'c:\users\smsoft\appdata\local\programs\python\python39\python.exe -m pip in
stall --upgrade pip' command.


이런 에러 뜨길래 하라는대로 python -m pip install --upgrade pip 해줬는데도

똑같은 pip 버전 오류가 뜨네요 ,,

cmd 관리자권한으로 실행해서 pip 업그레이드도 해봤는데 ㅠ 뭐가 문제일까요?

구글링해서 나온건 거의 다 해본거같아요 ..

0
  • 답변 3

  • Flex 해서 샀다
    257
    2021-08-18 17:30:17

    which pip

    which python

    하셔서 그 실행파일들 위치를 보세요~

  • 스프링링링
    611
    2021-08-18 17:32:04

    Flex 해서 샀다 

    cmd 창에서 which 가 안먹는거 같네요 ㅠ

    'which' is not recognized as an internal or external command,
    operable program or batch file.


  • Flex 해서 샀다
    257
    2021-08-18 18:03:50

    아 윈도시군요...

    which 가 아닌
    where 이거나
    Get-Command 였던 것 같네요

  • 로그인을 하시면 답변을 등록할 수 있습니다.